乐虎游戏|乐虎国际登录|欢迎你

虚拟化架构下虚拟交换机和分布式虚拟交换机解析

日期:2019-12-05编辑作者:计算机资讯

在VMware vSphere虚拟化架构下服务器可以虚拟出交换机来供虚拟机使用,虚拟交换机可分为两种,vSwitch虚拟交换机和vNetwork分布式虚拟交换机。


ESXI 5.0 虚拟机的网络适配器兼容性列表

   目前虚拟化应用比较广泛,通常情况下,一台物理主机在安装VMware ESXi或Hyper-V虚拟机软件后,可以在一台物理主机上创建多个虚拟机,并且创建的每个虚拟机可以像原来的物理一样对外提供服务,这无疑可以充分利用服务器的资源,达到节省电力、节省空间的目的。但大多数朋友们在使用虚拟机的时候,也有一个问题:就是物理主机性能已经够高,一般情况下配置了64GB内存、2个6核心的intel的CPU的主机,可以创建30~60台虚拟机。但物理主机一般只配置2~4块网卡,每个网卡只连接一个网段。而企业网络中可能划分了多个VLAN,这样,这些虚拟机怎样才能灵活的使用不同网段的地址呢?要解决这个问题,就需要让“虚拟交换机支持VLAN”,本文即介绍这方面的内容。

虚拟交换机vSwitch由ESXI内核提供,为一个虚拟的交换机,用于连接不同的虚拟机及管理界面。vSwitch可由一块或多块vmnic组成,不同的vSwitch无法使用同一vmnic。默认会安装第一台虚拟交换机vSwitch0,用于主控台,虚拟机联机等功能。ESXI的所有网络操作都是基于port/port group与vmnic,vSwitch之间的。

 

1 实验环境概述

如果要在VMware ESXi中,创建的虚拟机,需要使用其他网段的地址,就需要在vSphere虚拟交换机中,仿照物理交换机,为虚拟端口划分VLAN。

VMware Workstation、VMware ESXi是虚拟机软件,可以在一台物理机上模拟多台“虚拟”的计算机,虚拟交换机也与此类似。虚拟交换机绑定物理网卡,“虚拟计算机”通过“虚拟交换机”的“虚拟机端口组”连接到“虚拟交换机”,再通过与虚拟交换机绑定的物理网卡与主机上其他网络中的计算机、虚拟机通讯。每个虚拟交换机可以绑定一个或多个物理网卡不绑定物理网卡的虚拟交换机,是不能直接与主机网络通讯的)。

虚拟交换机绑定物理网卡所连接的交换机端口的属性,决定了虚拟交换机是否可以划分VLAN。简单来说,如果物理网卡连接到一个普通的交换机,或者连接到三层交换机的一Access端口即普通的划分了VLAN的端口),则这个物理网卡绑定的虚拟交换机,只能设置成该Access端口所指定的VLAN;如果物理网卡连接到三层交换机的Trunk端口,则可以在与这个物理网卡绑定的虚拟交换机划分或添加)虚拟机端口组,添加的每个端口组可以划分或指定一个VLAN,并通过所连接的三层交换机,与网络中其他计算机通讯。下面通过一个具体的实例进行介绍。

要在虚拟交换机中实现VLAN功能,需要与网络中的三层交换机配合使用,本节实验拓扑如图1-1所示。

图片 1

图1-1 虚拟交换机网络拓扑

在图1-1的拓扑中,有一台三层交换机,一个有两个网卡的服务器。在三层交换机中,划分了VLAN2001、VLAN2002、VLAN2003、VLAN2004、VLAN2005、VLAN2006共6个VLAN。各VLAN的网段如表4-1所示。

表4-1 三层交换机划分VLAN、地址及网关  

VLAN

所属地址

网关地址

VLAN2001

172.18.91.0/255.255.255.0

172.18.91.254

VLAN2002

172.18.92.0/255.255.255.0

172.18.92.254

VLAN2003

172.18.93.0/255.255.255.0

172.18.93.254

VLAN2004

172.18.94.0/255.255.255.0

172.18.94.254

VLAN2005

172.18.95.0/255.255.255.0

172.18.95.254

VLAN2006

172.18.96.0/255.255.255.0

172.18.96.254

三层交换机的主要配置参数如下:

<3526b>disp curr

#

sysname 3526b

#

dhcp-server 1 ip 172.18.96.1 172.18.96.5

#

vlan 2001

vlan 2002

vlan 2003

vlan 2004

vlan 2005

vlan 2006

interface Vlan-interface2001

ip address 172.18.91.254 255.255.255.0

dhcp-server 1

#

interface Vlan-interface2002

ip address 172.18.92.254 255.255.255.0

dhcp-server 1

#

interface Vlan-interface2003

ip address 172.18.93.254 255.255.255.0

dhcp-server 1

#

interface Vlan-interface2004

ip address 172.18.94.254 255.255.255.0

dhcp-server 2

#

interface Vlan-interface2005

ip address 172.18.95.254 255.255.255.0

dhcp-server 1

#

interface Vlan-interface2006

ip address 172.18.96.254 255.255.255.0

dhcp-server 2

#

interface Ethernet0/1

port access vlan 2001

#

interface Ethernet0/2

port access vlan 2001

#

interface Ethernet0/3

port access vlan 2002

#

interface Ethernet0/4

port access vlan 2002

#

interface Ethernet0/5

port access vlan 2003

#

interface Ethernet0/6

port access vlan 2003

#

interface Ethernet0/7

port access vlan 2004

#

interface Ethernet0/8

port access vlan 2004

#

interface Ethernet0/9

port access vlan 2005

#

#

interface Ethernet0/14

port access vlan 2006

#

interface Ethernet0/15

port access vlan 2006

#

interface Ethernet0/16

port access vlan 2006

#

interface Ethernet0/23

port link-type trunk

port trunk permit vlan all

interface Ethernet0/24

port link-type trunk

port trunk permit vlan all

interface GigabitEthernet1/1

#

在这台服务器上安装了VMware ESXi 5.1,这台服务器的第一个网卡连接到一个Access端口,该端口划分为VLAN2006,同时这个网卡设置了管理地址172.18.96.11;另一个网卡连接到交换机的Trunk端口连接到交换机的23或24端口)。

接下来我们看一下,怎样为虚拟交换机启用VLAN功能,并将其分配给虚拟机使用。

 

 

2 为连接到Trunk端口的网卡添加虚拟交换机

使用vSphere Client连接到VMware ESXi Server,在“配置→网络”中,可以看到,当前只有一个虚拟交换机,并且为该虚拟交换机分配了管理地址172.18.96.11,如图1-2所示。

图片 2

图1-2 当前网络

1)在图1-2中,单击“添加网络”链接,进入“添加网络向导”对话框,在“连接类型”中选择“虚拟机”。

2)在“虚拟机-网络访问”对话框,选择“创建vSphere标准交换机”,并选择第二块网卡即连接到交换机Trunk端口的网卡),如图1-4所示。

图片 3

图1-4 创建标准交换机

3)在“端口组属性”选项组中,在“网络标签”处添加第一个可用VLAN的标签,在此添加VLAN2001,在“VLANID”文本框中输入对应的VLAN,在此为2001,如图1-5所示。

图片 4

图1-5 添加网络标签及选择VLAN

4)在“即将完成”对话框,显示了要添加的虚拟机端口组。

返回到vSphere Client控制台后,可以看到,已经添加了第二个标准交换机,如图1-7所示。在此标准交换机中只有VLAN2001的虚拟机端口组。

图片 5

图1-7 添加虚拟交换机完成

 

就需要在vSphere标准交换机(vSphere Standard Switch,vSS)和vSphere分布式交换机(vSphereDistributed Switch,vDS)之间做出选择。
默认
vmnic0一张物理网卡
vSwitch0一个标准交换机
两个网络即
VM Network            虚拟机端口组
Management Network  vmkernel端口

3 为其他VLAN添加虚拟机端口组

在前面的操作中,在创建虚拟交换机的同时,已经添加了VLAN2001的虚拟机端口组,接下来要为VLAN2002~VLAN2006添加虚拟机端口组,以添加VLAN2002为例,其他与此类似。

1)在图1-7中,选择第二个虚拟交换机,单击“属性”链接,打开“vSwitch1属性”对话框,单击“添加”按钮,如图1-8所示。

图片 6

图1-8 添加虚拟机端口组

2)在连接类型中选择“虚拟机”。

3)在“端口组属性”中,在“网络标签”中添加VLAN2002,在“VLAN”文本框中输入对应的VLAN2002,如图1-10所示。

图片 7

图1-10 设置虚拟机端口组名称

4)在“即将完成”对话框,单击“完成”按钮,完成虚拟机端口组的添加。

5)返回到“vSwitch1属性”对话框,接下来,单击“添加”按钮,继续添加其他虚拟机端口组,这可以参照1)~4)步,依次为VLAN2003~VLAN2006添加,这些不一一介绍。当所有的虚拟机端口组添加完成后,单击“关闭”按钮返回。

返回到vSphere Client控制台后,可以看到两个虚拟交换机的情况,如图1-14所示。

图片 8

图1-14 添加完成的虚拟交换机及虚拟机端口组

 确认配置,完成添加之后可以看到esx服务器的网络中多了一个vswitch1的虚拟交换机。

 

4 在虚拟机中验证

以后在虚拟机使用中,为虚拟机分配对应的虚拟机端口组,即分配到指定的VLAN。下面通过实验验证。

1)启动一台虚拟机,并修改虚拟机属性,先将网络标签修改为VLAN2001,如图1-15所示。

图片 9

图1-15 修改虚拟机网络属性

2)进入虚拟机,查看当前的网络配置,如图1-16所示。可以看到,当前计算机获得的是172.18.91.200的IP地址,这符合表4-1的分配网络中配置了DHCP服务器)。

图片 10

图1-16 查看当前IP地址

3)然后使用ping命令,测试到其他网段的连通性,可以测试到DHCP服务器172.18.96.1的连通性,如图1-17所示。从图中可以看到,测试非常成功!

图片 11

图1-17 测试网络连通性

4)然后将虚拟机的网络改为另一网段,例如VLAN2005,如图1-18所示。

图片 12

图1-18 修改虚拟机网络属性

5)再次进入虚拟机,将网卡禁用再启用,再次进入命令提示符,查看当前地址是否为VLAN2005的地址,并使用ping命令测试,如图1-19所示,从图中看到,测试仍然是成功的。

图片 13

图1-19 在VLAN2005网段测试

说明】也可以将连接ESXi 网卡的交换机端口直接设置为“Trunk”,然后在管理地址中设置VLAN也是可以的。

本文出自 “王春海的博客” 博客,请务必保留此出处

ESXi或Hyper-V虚拟机软件后,可以在一台物理主机上创建多个虚拟机,并且...

图片 14

这里选择了两块网卡;这两块网卡都是做管理用的。之所以选择两块网卡完全是响应官方要求管理网络的冗余。防止一块网卡出现单点故障造成脱管。如果预算有限完全可以4块网卡进行部署。4块网卡分作用为:管理网络、存储网络、HA和VMotion走同一块网卡;这样可能会影响迁移效果。这些网卡至少是1000M全双工;官方推介10G速率的网卡。VLAN的配置不建议在这里配置;在vcenter里面配置更好。

我们可以添加的虚拟交换机有3种,一种就是上面演示的为虚拟机提供端口的交换机;一种是VMkernel,用来连接iSCSI和NFS存储,或者用来做vMotion;还有一种是Service Console服务控制台,用来配置IP管理esx主机。

网络

注意:我们可以让新建的虚拟交换机对应使用一块网卡也可以让它对应使用多块网卡,这样可以起到多网卡负载平衡和故障网卡的切换作用。


一、 标准交换机网络
二、 分布式交换机网络
三、 将标准交换机迁移到分布式交换机网络
四、 部署安装思科Nexus 1000V交换机
在理解VMware vSphere 5.1的网络之前先了解下概念:
物理网络是为了使物理机之间能够收发数据而在物理机间建立的网络。VMware ESXi 运行于物理机之上。
虚拟网络是运行于单台物理机之上的虚拟机之间为了互相发送和接收数据而相互逻辑连接所形成的网络。虚拟机可连接到在添加网络时创建的虚拟网络。

图片 15

物理以太网交换机管理物理网络上计算机之间的网络流量。一台交换机可具有多个端口,每个端口都可与网络上的一台计算机或其他交换机连接。可按某种方式对每个端口的行为进行配置,具体取决于其所连接的计算机的需求。交换机将会了解到连接其端口的主机,并使用该信息向正确的物理机转发流量。交换机是物理网络的核心。可将多个交换机连接在一起,以形成较大的网络

下面简单说一下vNetwork分布式虚拟交换机及它的添加使用

vSphere 标准交换机的运行方式与物理以太网交换机十分相似。它检测与其虚拟端口进行逻辑连接的虚拟机,并使用该信息向正确的虚拟机转发流量。可使用物理以太网适配器(也称为上行链路适配器)将虚拟网络连接至物理网络,以将 vSphere 标准交换机连接到物理交换机。此类型的连接类似于将物理交换机连接在一起以创建较大型的网络。即使 vSphere 标准交换机的运行方式与物理交换机十分相似,但它不具备物理交换机所拥有的一些高级功能。

vNetwork分布式虚拟交换机其实就是将几台ESX服务器的虚拟交换机合并成一个大的虚拟交换机,所有的客户端都接入到这个大的交换机中,适合于大规模的网络部署。

vSphere Distributed Switch 在数据中心上的所有关联主机之间充当单一交换机。这使得虚拟机可在跨多个主机进行迁移时确保其网络配置保持一致。分布式端口是连接到主机的 VMkernel 或虚拟机的网络适配器的 vSphere Distributed Switch 上的一个端口。端口组为每个端口指定了诸如宽带限制和 VLAN 标记策略之类的端口配置选项。网络服务通过端口组连接到标准交换机。端口组定义通过交换机连接网络的方式。通常,单个标准交换机与一个或多个端口组关联。分布式端口组是与 vSphere Distributed Switch 相关联的端口组,用于指定各成员端口的端口配置选项。分布式端口组可定义通过 vSphere Distributed Switch 连接到网络的方式。

如图示:

连接类型

图片 16

每一个交换机的连接类型决定了这个交换机的网络流量。连接类型分为两种:虚拟机和VMkernel,其中虚拟机指的是此交换机用于处理虚拟机的网络流量,而VMkernel指的是ESXi功能服务的流量包括vMotion(实时迁移网络)、iSCSI与NFS(存储访问网络)、主机管理(management网络)等,

本文由乐虎游戏发布于计算机资讯,转载请注明出处:虚拟化架构下虚拟交换机和分布式虚拟交换机解析

关键词:

乐虎国际登录:Win2008 R2 mysql 5.5 zip格式mysql 安装与配置

Win2008 R2 mysql 5.5 zip格式mysql 安装与配置 Win2008 R2 zip格式mysql 安装与配置 一、百度mysql5.6 ZIP 64位免安装版 下载好后 解...

详细>>

SQL计算timestamp的差值的方法

SQL计算timestamp的差值的方法 SQL计算timestamp的差值的方法 mg电子游戏网址 , mg娱乐电子游戏 , 概述 有时候我们需要按...

详细>>

EBET视讯直播mysql sql语句质量调优轻松实例

mysql sql语句性能调优简单实例 mysql sql语句性能调优简单实例 在做服务器开发时,有时候对并发量有一定的要求,有时...

详细>>

29个非常流行的jQuery提示信息插件

在网站的设计中,提示信息是非常细微的功能,但是起着非常重要的作用。如果你的网站中提示信息做的比较好,会...

详细>>