乐虎游戏|乐虎国际登录|欢迎你

mg电子游戏娱乐场Liunx PHP的GD库 增多 jpeg 文件的援救

日期:2019-11-05编辑作者:计算机资讯

GD Support enabled

 代码如下

本文永久更新链接地址:http://www.linuxidc.com/Linux/2014-11/109911.htm

很显然多了个 JPEG Support enabled

tar -zxvf  jpegsrc.v8b.tar.gz
cd jpeg-8b

显然gd 没有支持jpeg 的,下面要安装 gd中的 jpeg

make && make install

如果你使用此函数提示php Fatal error: Call to undefined function imagecreatefromjpeg()

查看phpinfo OK了

安装前我的phpinfo 如下:
gd
GD Support enabled
GD Version bundled (2.0.34 compatible)
FreeType Support enabled
FreeType Linkage with freetype
FreeType Version 2.2.1
GIF Read Support enabled
GIF Create Support enabled
PNG Support enabled
libPNG Version 1.2.10
WBMP Support enabled
XBM Support enabled

执行完这些 系统就会提示你  gd.so 生成目录

这个错误是因为没有安装gd 的jpeg, 虽然你用phpinfo 查看有gd但 gd 不支持 jpeg

./configure --with-php-config=/usr/local/php/bin/php-config --with-jpeg-dir=/usr/local/jpeg/

首先,打开php.ini,找到“extension=php_gd.dll”,然后去掉前面的“;”注释,重启apache即可。

GD Support enabled
GD Version bundled (2.0.34 compatible)
GIF Read Support enabled
GIF Create Support enabled
JPEG Support enabled
libJPEG Version 8
PNG Support enabled
libPNG Version 1.2.49
WBMP Support enabled
XBM Support enabled

如果还出现此类问题,先检查php.ini的extension_dir值是哪个目录,在那个目录下检查有无php_gd.dll,没有的话请下载php_curl.dll,再把php目录中的libeay32.dll和ssleay32.dll拷到c:windowssystem32里面,重启apache,OK!

yum install libjpeg-devel freetype-devel libpng-devel
make clean后重新./configure
make&make install

if(!imagecreatefromjpeg("./testimg.jpg"))
{
echo "imagecreatefromjpeg(testimg.jpg) failed!n)";
}
else
{
echo "imagecreatefromjpeg(testimg.jpg) succn)";
}

下面进入到 php 源码目录下 的 ext 下的 gd目录

安装后查看phpinfo

本文由乐虎游戏发布于计算机资讯,转载请注明出处:mg电子游戏娱乐场Liunx PHP的GD库 增多 jpeg 文件的援救

关键词:

在CentOS上安装rvm

本文系统CentOS6.5 x64 如果是Ubuntu系统,先安装编译环境 Ruby On Rails是一个用Ruby语言写的开源Web框架,和J2EE,PHP等类似...

详细>>

CentOS7 yum安装LNMP以及LAMP

CentOS 7.11053最小化安装LNMP通过yum安装,由于CentOS7没有MySQL的yum源,所以要自己安装MySQL的yum源,但是安装上了,在我这...

详细>>

Nginx 作为Web Server 的优化要点

Nginx既可用作Web Server,也可用作反向Proxy,这里先研商作为WebServer的平淡无奇优化主旨。 常用优化中央 Nginx使用的是...

详细>>

本地启动spark-shell

出于spark-1.3作为叁个里程碑式的公布,插足过多的功用特色,所以,有须求能够的钻研豆蔻年华把,spark-1.3需求scala-2.10.x的...

详细>>